Thank You!

Click the button below to download TREAT 3.5.1

Important Note About Older TREAT Versions: TREAT 3.4 and TREAT 3.3 are Not Backwards Compatible with older versions. The newest TREAT version 3.5 is backwards compatible.

With all the great new features we’ve added, it’s important to know that TREAT files created/edited with TREAT 3.3 or 3.4 will not open in older versions of TREAT. Of course older files can be opened and edited in TREAT 3.3, but it is not backwards compatible due new surfaces, and overall improvements which would go unrecognized in older versions.

To download the older: TREAT 3.3.1 click here

To download the older TREAT 3.2.5 click here

Start typing and press Enter to search